how to run the java proxy?

https://github.com/bwapi/bwapi
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable
hamsterofdeath
Posts: 7
Joined: Fri Feb 26, 2010 9:46 pm
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

how to run the java proxy?

Postby hamsterofdeath » Fri Feb 26, 2010 9:55 pm

i dled the chaoslaunchner, and after starting a game, i get some messages from bwapi, so the dll injection worked. it tells me it couldn't load the ai module which isn't surprising because i did not make one yet. but how to go on from here?
i compiled & started the java proxybot, but it just tells me that it's waiting for a client

nothing in the 2.6.1 proxybot tells me how to "plug it in"

i found a directory called "bwapi-data" in some zip files via google. copied them into the starcraft-directory and got this:


should i use admin mode/not admin mode for starcraft? use vista/7 32/64 bit? seems my problem is getting the ai module itself run, the java proxy doesn't crash
do i need a specific os? do i have to use an uncracked version?
hamsterofdeath
Posts: 7
Joined: Fri Feb 26, 2010 9:46 pm
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Postby hamsterofdeath » Sat Feb 27, 2010 8:43 am

tried running the same stuff on a 32 bit vista machine in admin mode. (admin mode crashes under win7&64bit)
got another error message telling me that mpfr-vc90-mt.dll is not found. how did anyone ever run this if dlls are missing?

got the dll from there


but then i get an error message telling me that the dll is broken and i should ask the one who gave it to me/reinstall the application it came with. which i cannot do since it is a simple zip file not even containig the missing dll.
hamsterofdeath
Posts: 7
Joined: Fri Feb 26, 2010 9:46 pm
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Postby hamsterofdeath » Sat Feb 27, 2010 9:40 am

i solved some riddles. some dlls are in the bwapi 2.6.1-zip in the windows-directory. the proxybots dll needs them, but didn't tell in its readmes which were non-existant. also, it seems the dlls do not work on windows 7 or 64 bit, or both, could not test any combination. i just know win7&64 crashes, vista&32bit works. maybe i need to recompile the dll for 64 bit?
hamsterofdeath
Posts: 7
Joined: Fri Feb 26, 2010 9:46 pm
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Postby hamsterofdeath » Sat Feb 27, 2010 11:43 am

krasi0
Posts: 254
Joined: Thu Dec 18, 2008 12:42 pm
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Postby krasi0 » Sun Feb 28, 2010 7:44 pm

Have you tried this version ?
hamsterofdeath
Posts: 7
Joined: Fri Feb 26, 2010 9:46 pm
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Postby hamsterofdeath » Mon Mar 01, 2010 10:38 am

yes, that's the one not working. i figured out it was my os, it works with vista/32 bit. however, the exampleaimodule locks up in or before the first frame, it just stops to send data. did anyone here get it working?
dayoung
Posts: 1
Joined: Sun Mar 21, 2010 3:51 am
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Postby dayoung » Sun Mar 21, 2010 4:39 am

I just setup BWAPI and the Java Proxy bot and it seems to run just fine

I tried it with a 32bit JVM and 64bit JVM in Eclipse and both worked fine.

I'm running

Windows 7 with
JDK 1.6.0_17 32bit
JDK 1.6.0_17 64bit

BWAPI 2.6.1

Eclipse 20090920-1017
Chaoslauncher 0.5.3
Starcraft 1.16.1

You must install BWAPI first! and follow all of their directions first!
Make sure you can run BWAPI before trying with java.

The dll issues you had were because you didn't install BWAPI correctly following their README file.

Good luck, I'll be messing with the Java proxy more so keep trying.

[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Return to “BWAPI (wrappers in other languages / questions and announcements related to BWAPI itself)”

Who is online

Users browsing this forum: No registered users and 10 guests