PYICE

Help - Resources - Discussion
User avatar
poiuy_qwert
Posts: 548
Joined: Sun Jan 13, 2008 2:14 am

Postby poiuy_qwert » Sun Mar 15, 2009 5:31 pm

Well Hydra totally missed this and recreated his topic anyway. Now that it has a PyDAT issue in it as well I don't feel inclined to split his post up and put them in the PyICE and PyDAT threads, so I let it stay and deleted his post above yours.

About your question, if you changed it and only want the change to effect one of the scripts then yes you would have to make a copy and update your jumps. But like you said you can decompile the scripts separately.
User avatar
poiuy_qwert
Posts: 548
Joined: Sun Jan 13, 2008 2:14 am

Postby poiuy_qwert » Sun May 17, 2009 3:33 am

Ah actually no that was my fault and has been fixed for the next release, which I hope to get out real soon. You'll have to move the default iscript.bin to LibsMPQscripts.
IskatuMesk
Posts: 329
Joined: Wed May 16, 2007 5:57 pm

Postby IskatuMesk » Tue May 19, 2009 5:52 am

Baja, are you compiling your scripts in parts (like mine) or in a single giant txt?

I noticed PyICE actually mixes up the Destroyer's script somehow. It didn't do it all the time, only recently during my massive testing process to try to find another issue. It started replacing the Init with one of the movement animations. Very weird.
User avatar
poiuy_qwert
Posts: 548
Joined: Sun Jan 13, 2008 2:14 am

Postby poiuy_qwert » Tue May 19, 2009 7:27 pm

[quote name='bajadulce' post='6467' date='May 18 2009, 05:48 PM']You prob meant to say create a libsdefault folder.[/quote]
Heh yeah, woops :P

[quote name='bajadulce' post='6467' date='May 18 2009, 05:48 PM']I seem to remember reading about negative values somewhere? Might have even been this topic? I was trying to compile some of my scripts with PyICE and am getting the following error: ...[/quote]
That was a stupid mistake on my part. In the current release PyICE can load/interpret/decompile negative valuesm, but then cant save the iscript.bin :S This has been fixed thanks.

[quote name='bajadulce' post='6467' date='May 18 2009, 05:48 PM']On a related note but somewhat a Help topic:
I'm also having a problem with ICeCC. Whenever I compile a new entry to my iscript, one of my units attack animations no longer works![/quote]
Well I have no idea how IceCC handles everything, but once you add the new entry you can try decompiling the broken one with IceCC and/or PyICE to see if something is wrong. Also iscript.bin has the same max size as aiscript.bin, 65535 bytes, or 65kb.

Return to “PyMS (poiuy_qwert's complete modding suite)”

Who is online

Users browsing this forum: Baidu [Spider] and 1 guest