Accel_T v1.52 by Equalizer

Help - Resources - AI Scripting - Grafting - Plugins - Modding Projects
Equalizer
Posts: 83
Joined: Wed Sep 23, 2009 3:49 am

Postby Equalizer » Fri Jul 13, 2012 2:52 am

[quote name='Taranok' date='12 July 2012 - 05:26 PM' timestamp='1342139193' post='10973']
Image

Here's what I have. That's the only SCV I killed that was building something.

[Red blotches show idle SCVs.]
[/quote]

Did the refinery ever get completed/destroyed?

If not then that's the source of the problem and unfortunately I don't think it is possible to fix.
User avatar
Taranok
Posts: 256
Joined: Tue Sep 07, 2010 9:41 pm

Postby Taranok » Fri Jul 13, 2012 6:32 am

nope, that's what I mentioned in an earlier post. it never got destroyed.
superone
Posts: 3
Joined: Mon Nov 21, 2011 8:37 am

Postby superone » Fri Jul 13, 2012 7:21 am

I think the issue with unfinished Terran buildings has been solved in the Entropy mode of BWAI Launcher v1.3.
(this thing)
index.php?showtopic=452

Just for an example I've added a simple replay of me doing a zealot rush on the default Blizzard Terran AI. The replay was recorded in the BWAIWar mode in the Launcher - if viewed in the same mode, the AI staggers after a certain SCV kill, however the same replay viewed in Entropy mode gives different results.
User avatar
Taranok
Posts: 256
Joined: Tue Sep 07, 2010 9:41 pm

Postby Taranok » Fri Jul 13, 2012 8:08 am

I believe somebody's AI inside the exe version has an edit so the AI won't lock up when the SCV building a CC at an expo is killed...

by the way when I played the TvT game it was from the AIvsAI package, maybe that's why you don't have that problem.
Equalizer
Posts: 83
Joined: Wed Sep 23, 2009 3:49 am

Postby Equalizer » Fri Jul 13, 2012 4:38 pm

[quote name='superone' date='13 July 2012 - 12:21 AM' timestamp='1342164106' post='10977']
I think the issue with unfinished Terran buildings has been solved in the Entropy mode of BWAI Launcher v1.3.
(this thing)
index.php?showtopic=452

Just for an example I've added a simple replay of me doing a zealot rush on the default Blizzard Terran AI. The replay was recorded in the BWAIWar mode in the Launcher - if viewed in the same mode, the AI staggers after a certain SCV kill, however the same replay viewed in Entropy mode gives different results.
[/quote]

Makes sense. That explains why when I watched Taranok's replay in Entropy mode it didn't line up.

I suppose the AIvsAI package should also include the patch to the scv control.

Edit:
a simple way to do this seems to be in the settings.txt file in the BWAIWar package to change
'targetmpq':u'APPDIR:LibsDataSEMPQ.exe',
to
'targetmpq':u'PKGDIR:Entropy3.exe',
User avatar
poiuy_qwert
Posts: 548
Joined: Sun Jan 13, 2008 2:14 am

Postby poiuy_qwert » Sat Jul 14, 2012 3:28 am

I believe there is a Firegraft EXE edit to fix that glitch (i believe its called something along the lines of "idle worker glitch" or something), and that is the reason Entropy 3 works.
User avatar
Archon_Wing
Posts: 903
Joined: Wed Jul 25, 2007 11:22 pm

Postby Archon_Wing » Wed Jul 18, 2012 9:38 pm

There's pretty much no reason to run any exe besides Entropy 3, aside from the cheating AI exe which also has that fix.
User avatar
Taranok
Posts: 256
Joined: Tue Sep 07, 2010 9:41 pm

Postby Taranok » Thu Sep 20, 2012 9:24 pm

Any luck with mech?

Return to “StarCraft Modding”

Who is online

Users browsing this forum: No registered users and 1 guest