BWAI Downgrader v1.16.1.e

Help - Resources - AI Scripting - Grafting - Plugins - Modding Projects
Freewills
Posts: 4
Joined: Wed Jul 30, 2008 1:50 am
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Postby Freewills » Wed Jul 30, 2008 6:37 am

Works great! 1.10 was broked on my other downgrader.
User avatar
ShadowFlare
Posts: 15
Joined: Tue Apr 15, 2008 7:23 am
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Postby ShadowFlare » Thu Aug 07, 2008 2:33 am

Heh, it isn't just the patch from the ToggleNX program I made that the no-cd patcher does. It also performs other modifications so that sfnocd.dll will automatically get loaded by Starcraft, so that it is able to perform its patches. But any kind of modification to Starcraft.exe on disk will make the integrity check on Battle.net fail. As far as I know, just simply failing the check won't get you banned, like if you forget you can't get on Battle.net with the exe mod and then you try to connect to Battle.net.

The no-cd patcher actually also works with 1.15.2, but there is no point to that, since the patch's only purpose is to emulate the 1.15.2 feature.
Halachee
Posts: 11
Joined: Sat Mar 29, 2008 7:24 am
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Postby Halachee » Thu Aug 07, 2008 6:59 pm

This works great on my system, thanks!

I could use a 1.12 patch for a mod I like to play sometimes. I too can't figure out how to get ShadowFlare's no-cd thing to work on my own. If you could add 1.12 to your downgrader, it would really help me out a lot.
Robsoie
Posts: 4
Joined: Fri Jan 25, 2008 2:41 pm
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Postby Robsoie » Fri Aug 08, 2008 11:09 pm

I knew the process was too simple, when all is going well, it will go bad as in the murphy law ;)

While there is no problem when downgrade to 1.15.1 , 1.15 , 1.14 , when downgrading to 1.10 , i quickly noticed all the blizzard skirmish maps are "invalid scenario" , meaning that at some point blizzard updated all the maps or the headers of all of them, and you can't read them in 1.10

I guess to correctly play some 1.10 skirmish i will have to uninstall all of starcraft then reinstall then patch to 1.10 to get the maps in the state they were before they were somehow updated by a more recent patch and made unreadable by 1.10, oh well, maybe another day.
a_of_s_t
Posts: 51
Joined: Sun Mar 23, 2008 5:39 am
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Postby a_of_s_t » Sat Aug 09, 2008 12:08 am

When I downgrade to 1.10, all my custom maps still work, just not Blizzard's.
IskatuMesk
Posts: 329
Joined: Wed May 16, 2007 5:57 pm
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Postby IskatuMesk » Thu Aug 14, 2008 6:53 am

1.10 is a superior version. I've been told that the aiscript.bin format was actually altered a bit 1.11+ and my tests all indicated that the AI was less functional in later versions. Its sensitivity to certain scripting methods changed with every patch. The most blatantly noticeable was related to zerg expanding on islands.

On top of this, blizzard's AI scripts are extremely large and messily coded, as is their habit of things.

Ultimately if you want a truly stable AI you will use the custom AI littered throughout this forum and stick with 1.10 like I do. Most people can't stomach the manliness of 1.10, however. :P
Robsoie
Posts: 4
Joined: Fri Jan 25, 2008 2:41 pm
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Postby Robsoie » Sat Aug 16, 2008 2:05 am

Custom maps downloaded from various places and that i played under current 1.15+ version seems to work in 1.10+, confirming that probably only Blizzard marked maps are incompatible (or at least most of them, as i did not tried everyone of them).

Thanks for the confirmation about the AI being more responsive in general and in custom scripts in 1.10, as i have not played online since years and don't plan to come back to it, AI battles are the only source of fun in Starcraft for me, so it is very good to know this about the AI and 1.10.
My various battles with all the different AI available will certainly become more fun.

[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Return to “StarCraft Modding”

Who is online

Users browsing this forum: No registered users and 1 guest