Help running AIs

Anything related on how to build / improve your AI using BWAPI, BWTA, BWSAL, etc.
Relurek
Posts: 2
Joined: Sat Sep 03, 2011 4:16 am

Help running AIs

Postby Relurek » Sat Sep 03, 2011 4:21 am

I'm having trouble loading any BWAPI AIs. When I run them (through Chaos Launcher), when I start the game, I get an error, usually saying some info cannot be written, and SC crashes. Could someone please help me learn to run an AI? Please use Berkeley's Overmind as an example. Please be as detailed as possible, I'm new to this. Thanks.
Heinermann
Posts: 362
Joined: Thu Apr 26, 2007 12:42 am

Postby Heinermann » Sat Sep 03, 2011 4:39 pm

Are you using the correct BWAPI version that the AI was compiled for?
Try also running in administrator mode.
Relurek
Posts: 2
Joined: Sat Sep 03, 2011 4:16 am

Postby Relurek » Sat Sep 03, 2011 5:03 pm

[quote name='Heinermann' date='03 September 2011 - 11:39 AM' timestamp='1315067995' post='10349']
Are you using the correct BWAPI version that the AI was compiled for?
Try also running in administrator mode.
[/quote]

It's set to run in administrator mode. Is there a way to set it up easily, so I don't have to have a different copy of Chaos launcher/BWAPI folders for each different bot that runs on a separate version? Sorry if this doesn't make too much sense, but is there something I can do DLL wise, to only have to write something in the ini file to "emulate" a different version of the program for the bot to run with? If not, whats the best way to go about having different versions of BWAPI?


EDIT: Also, I forgot to mention, what if the bot comes with a remote batch file? (like Overmind does) I run the batch file, but it says "The system cannot find the path specified".

Return to “AI development (BWAPI Bots)”

Who is online

Users browsing this forum: No registered users and 1 guest