Search found 10 matches

by SilverG
Fri Feb 08, 2013 5:32 pm
Forum: PyMS (poiuy_qwert's complete modding suite)
Topic: Help. PyAI not working as it did in older version?
Replies: 20
Views: 1072

Re: Help. PyAI not working as it did in older version?

Sorry, no show off videos. . . the AI still needs a bit of tweaking :)

I can only tell you this: the AI researches till the 10th level of weapons and armor, and has an attack randomizer.
by SilverG
Fri Feb 08, 2013 11:47 am
Forum: PyMS (poiuy_qwert's complete modding suite)
Topic: Help. PyAI not working as it did in older version?
Replies: 20
Views: 1072

Re: Help. PyAI not working as it did in older version?

Oh. . . thaaaaat. . . :)

Well just to inform you. . . I've FINALLY implemented the (Terran) AI that I've been working on, and it works.
by SilverG
Fri Feb 08, 2013 6:11 am
Forum: PyMS (poiuy_qwert's complete modding suite)
Topic: Help. PyAI not working as it did in older version?
Replies: 20
Views: 1072

Re: Help. PyAI not working as it did in older version?

Oh. . . thx for the advice

Btw what is a Vanilla AI?
by SilverG
Thu Feb 07, 2013 10:39 pm
Forum: PyMS (poiuy_qwert's complete modding suite)
Topic: Help. PyAI not working as it did in older version?
Replies: 20
Views: 1072

Re: Help. PyAI not working as it did in older version?

the syntax errors were fixed, but still nothing. I want it to run on any game mode, be it melee, free for all, top vs bottom etc.
by SilverG
Thu Feb 07, 2013 8:12 pm
Forum: PyMS (poiuy_qwert's complete modding suite)
Topic: Help. PyAI not working as it did in older version?
Replies: 20
Views: 1072

Re: Help. PyAI not working as it did in older version?

here it is: extdef D:/Program Files/Starcraft BW/PyMSwinEXE/unitdef.txt # stat_txt.tbl entry 1047: Terran Custom Level<0> TMCu(1047, 000, aiscript): start_town() transports_off() farms_timing() groundmap_jump(TGM 000) goto(TIM) --TGM 0000-- random_jump(30, Resource_gathering) random_jump(100, Marine...
by SilverG
Thu Feb 07, 2013 7:21 pm
Forum: PyMS (poiuy_qwert's complete modding suite)
Topic: Help. PyAI not working as it did in older version?
Replies: 20
Views: 1072

Re: Help. PyAI not working as it did in older version?

The problem still persists . . . . I've moved my edited aiscript.bin the the desired mod's *.exe via WinMPQ, under scripts\aiscrip.bin, and the game doesn't use it. I've even edited the flags in the ai, such as clearing the "broodwar only", "requires a location" and "invisib...
by SilverG
Thu Feb 07, 2013 6:27 am
Forum: PyMS (poiuy_qwert's complete modding suite)
Topic: Help. PyAI not working as it did in older version?
Replies: 20
Views: 1072

Re: Help. PyAI not working as it did in older version?

True :)

Well I've did the X->Z (xibbit :P ) and put in the Unitdef.txt in the Manage External Definition. Since the programe PyAI didn't do it at installation/unpacking.
So this is a must do "objective" :) for all of you who are unpacking the PyMS.exe and want to edit PyAI's.

Cheers!
by SilverG
Wed Feb 06, 2013 10:30 pm
Forum: PyMS (poiuy_qwert's complete modding suite)
Topic: Help. PyAI not working as it did in older version?
Replies: 20
Views: 1072

Re: Older version?

As BWAI I was referring to the game itself sorry. . . . :)

Anyway did some tweaking here and there. . and after a couple of minutes everything is as it should be. . . Thank you for your help and understanding :)
by SilverG
Wed Feb 06, 2013 10:06 pm
Forum: PyMS (poiuy_qwert's complete modding suite)
Topic: Help. PyAI not working as it did in older version?
Replies: 20
Views: 1072

Re: Older version?

I am putting it in the scripts/ section of the *.exe file. The problem is that PyAI doesn't recognize the string that BWAI is using for example in the older version it was easy just to put Build(1, hatchery, 200). . . in the new 2.4 PyAI I have to switch the "hatchery" or any other buildin...
by SilverG
Wed Feb 06, 2013 4:44 pm
Forum: PyMS (poiuy_qwert's complete modding suite)
Topic: Help. PyAI not working as it did in older version?
Replies: 20
Views: 1072

Help. PyAI not working as it did in older version?

Hello all, I'm relatively new to the forums, but not to SC BW. What's with the new version of PyMS? Each time I make my own AI (edit the things needed, so that the AI script wouldn't need a location - which has been working with the older version of PyAI) and as soon as I add it to the MOD that's I'...

Go to advanced search